Composer package is updated, but core still asks to update

27/07/2018


I am using Drupal 8.5.5. On admin/modules/update I red the following message.

Bootstrap (Theme)
Bootstrap (Theme) 8.x-3.11 update to 8.x-3.12 (Release notes)

The composer.json contains the following text.

"require": {
    ...
    "drush/drush": "^9.3",
    "drupal/core": "~8.5.3",
    "drupal/bootstrap": "^3.12" 
},

I then ran composer install and installed Bootstrap 8.x-3.12. When I run composer show drupal/bootstrap it outputs the following.

name     : drupal/bootstrap
descrip. : Built to use Bootstrap, a sleek, intuitive, and powerful front- 
end framework for faster and easier web development.
keywords :
versions : * 3.12.0 
type     : drupal-theme
license  : GNU General Public License v2.0 only (GPL-2.0) (OSI approved) 
https://spdx.org/licenses/GPL-2.0.html#licenseText
source   : [git] https://git.drupal.org/project/bootstrap 8.x-3.12
dist     : [zip] https://ftp.drupal.org/files/projects/bootstrap-8.x-3.12.zip 8.x-3.12
names    : drupal/bootstrap

requires
drupal/core ~8.0

When I go back to admin/modules/update Drupal still says Bootstrap 8.x-3.11 is installed. I have ran drush updb and drush cr to no avail. I am confused as to why it is not running composer’s version of Bootstrap.

Why?

EDIT:
When I run drush pm:list –package bootstrap the command line returns:

Bootstrap (bootstrap) Enabled 8.x-3.11 . Yet composer’s version is on 8.x-3.12.

قالب وردپرس